UK Whitegoods Domestic Appliance Help & Support Forums

Dishwasher Help Forum

Beko DIN26X20 Display

Forum to get help and advice on any dishwasher problems that you may have for full size, slimline dishwashers. For dishwasher spares click here

Get spare parts for dishwashers

Buy dishwasher spare parts in our store for all major dishwasher makes and models including many low cost compatible spares or contact us and we will find the parts you need for you

 Get Spare Parts Cheap

Buy many cheap spare parts in our store including many compatible parts for all major brands including Hotpoint, Whirlpool, Smeg, AEG, Beko, LG, Samsung and many, many more.

 Click to email, tell us what you need and we'll find the parts you need

shop spare parts
    
    
    
    
     
    
    

by blueandy » Wed Sep 13, 2017 11:30 am

Hi there,

My dishwasher, though still functioning, seems to have a display panel problem. The display flashes a series of incomprehensible symbols which eventually stay fixed on a set of (again) incomprehensible symbols. The machine still goes through a cycle when I load and start as normal. However, it seems to go through a very long cycle (about 3 hours), then makes an unusual noise (buzzing, but not loudly), before ending with a series of beeps as normal. The load is thoroughly cleaned, but I'm concerned about the cycle length and lack of controllability - particularly since I usually only use the eco setting (45 mins length). I have tried switching off and removing the plug from the socket for several periods.

Any ideas or guidance on possible repair gratefully received.
User avatar
blueandy
Whitegoods Newbie
Whitegoods Newbie
 
Posts: 1
Joined: Wed Sep 13, 2017 11:19 am

 Dishwasher basket wheels and rollers

Get a replacement basket wheels and rollers for your dishwasher in our store here including built in and integrated dishwashers for major makes including Lamona, Smeg, Beko, Hotpoint, Bosch and many more

Dishwasher basket wheels for most dishwashers including popular makes like Hoover, Zanussi, Smeg, Diplomat, Hygena and many more

by kwatt » Wed Sep 13, 2017 12:53 pm

I had a quick look and about all I can think that might cause that is the board, possibly due to spillage on it especially so as you say it seems to be working okay.

It's a bit of a punt of course but the board is this one:

https://shop.ukwhitegoods.co.uk/1739170 ... ntrol-card

It's nil stock UK and EU though with no fixed ETA presently.

K.
"Sometimes you get the best light from a burning bridge" Don Henley

Cheap appliance spare parts in our store Find an appliance repair company here
User avatar
kwatt
Appliance Forum Administrator
Appliance Forum Administrator
 
Posts: 26101
Joined: Sun Jun 15, 2003 12:00 am
Location: Scotland



 UK Whitegoods Spare Parts Store

Buy spare parts in our store from our team of spares experts that have a vast knowledge of the domestic appliance industry and access to over 14 million spare parts who will help you find any part you need and get it to you as fast and cheap as possible

 Use this link to email us, tell us what you need and we'll find parts for you

shop spare parts
    
    
    
    
     
    
    

Return to Dishwasher Help Forum

http://www.ukwhitegoods.co.uk/