UK Whitegoods Domestic Appliance Help & Support Forums

Cooker And Oven Forum

NEFF Fan Oven not working U1661N0GB/02

This forum is for any cooking appliances that you need help with like cookers, ovens, hobs, hoods & microwaves. For cooker and oven spares click here

Get oven and cooker spare parts

Buy spare parts in our store for built in ones and cookers including range cookers with many low cost compatible spares available or contact us and we will find the parts you need for you

 Oven & cooker fan motors

Should you need a new fan motor for your built in oven, cooker or range cooker that are a common cause of noise or uneven cooking then we can supply almost any for UK ovens and cookers often at low prices and with many compatible fan motors stocked. Find replacement fan motors in our store for all major brands including Britannia, Bosch, Beko, Lamona, Rangemaster, Smeg and many more

Buy oven fan motors for built in ovens and cookers online

by easyeieio » Sun Feb 05, 2017 7:39 pm

Hi all, I'm hoping someone might be able to help me diagnose what the problem is with my NEFF oven please - model U1661N0GB/02 . Inherited with a house we've moved into. There seems to be a problem with the fan oven mode , whereby it doesn't get seem to get hot enough, we leave it for ages, but it never heats up fully.

Here's what happens, turn oven on, in fan mode Image, the temperature light comes on, and the oven light. The element seems to get hot, and when I open the door it can be seen glowing red ( see image below )

Image

However after a short while the glow goes out. The main fan which also can be seen in that pic at the back is not spinning, but I can spin it freely if with my finger ( when the oven is cold! ) I can hear another fan somewhere , guess that's something else? After a long time the oven heats up a bit, but not to full temperature and seems to get cold again really quickly.

The conventional oven Image seems to work fine, gets up to temperature and cooks well ( on all other settings )

I'm guessing it might just well need a new fan / motor mechanism (this one I think https://shop.ukwhitegoods.co.uk/mtr295-oven-fan-motor ) but before I order it, I wanted to check in case there could be another problem. Should the element be glowing throughout , has that had it too, or is that happening because the fan is not working? Would it be a plan to order a new element anyway?

Any thoughts and ideas very much appreciated!

Many thanks
Ian
User avatar
easyeieio
Appliance Forum User
Appliance Forum User
 
Posts: 6
Joined: Mon Jan 18, 2010 12:00 am

 Support The Repair Community

How you can help in supporting out community is simple, just just use repairers from our online repair search if you need an appliance repaired

Buy any parts you need in our store that helps fund and maintain this website and the free use of it.

Don't use an adblocker.

That's all you need to do and we all appreciate your support and assistance.

by kaibart » Sun Feb 05, 2017 8:04 pm

Yes sounds like the main fan motor to me
User avatar
kaibart
Valued Contributor
Valued Contributor
 
Posts: 459
Joined: Mon Aug 01, 2016 7:48 pm

by easyeieio » Mon Feb 06, 2017 5:34 am

Cheers, is it normal for the element to stop glowing red then after initial start up? Or is that because fan is not working?
User avatar
easyeieio
Appliance Forum User
Appliance Forum User
 
Posts: 6
Joined: Mon Jan 18, 2010 12:00 am

by Martin » Mon Feb 06, 2017 8:28 am

Without the fan turning immediately the element switches on it will glow red and eventually, and very quickly burn out!

Fit a new fan motor and you might just save the day.
User avatar
Martin
Appliance Master
Appliance Master
 
Posts: 26287
Joined: Thu Jun 19, 2003 12:00 am
Location: Over the hill

by easyeieio » Mon Feb 06, 2017 10:48 am

Thank you for the advice guys, I'll report back once I removed it and (hopefully!) sorted it
Cheers
Ian
User avatar
easyeieio
Appliance Forum User
Appliance Forum User
 
Posts: 6
Joined: Mon Jan 18, 2010 12:00 am

by thelearner » Fri Feb 17, 2017 10:28 am

Many years ago I had the same problem. I bought a new fan motor.
When I removed the inner grill, I noted my wife had been clattering it hard with the trays/dishes etc, and one of the grills was bent back in causing the fan to be unable to turn.
I fitted the new motor anyway, and years later it's still working fine - first step I would always do is remove the inner cover and see if the fan works with it removed.

Remember when removing fan the nut is a left hand thread usually. Clockwise to loosen.

Good luck
User avatar
thelearner
Appliance Forum User
Appliance Forum User
 
Posts: 14
Joined: Tue Aug 17, 2010 12:00 am

by easyeieio » Fri Feb 17, 2017 10:59 am

Just thought I'd report back, and say thank you for the assistance. I took the oven out and replaced the fan, and the element too for good measure, whilst I had it in bits . The old fan span when pushed, but I guess the motor had gone - the whole thing was incredibly gummed up with nastiness from years of use. All cleaned up, installed, and working now, fantastic hot oven at last!
User avatar
easyeieio
Appliance Forum User
Appliance Forum User
 
Posts: 6
Joined: Mon Jan 18, 2010 12:00 am




Return to Cooker And Oven Forum