UK Whitegoods Domestic Appliance Help & Support Forums

General Enquiries And Questions

HJA2520 Oven Hood Motor

General questions of any nature relating to the appliance industry can be posted here or questions about the UK Whitegoods appliance website or forums

Spare parts for all domestic appliances

“Spare
Get spare parts including accessories and filters for your kitchen appliances in our store for all major makes and models including many low cost spares or contact us and we will find the parts for you

Buy spare parts in our store from our team of spares experts that have a vast knowledge of the domestic appliance industry and will help you find any part you need and get it to you as fast and cheap as possible

Use this link to email us, tell us what you need and we'll find parts for you
shop spare parts

by Cameron Bruce » Wed Feb 15, 2017 5:23 pm

Hi,

I think the motor in my oven hood fan has broken and I was told to get advice from you guys. It's a Howdens oven hood model number HJA2520 which stopped working on Monday, so can you help?

Regards,

Cameron Bruce
User avatar
Cameron Bruce
Whitegoods Newbie
Whitegoods Newbie
 
Posts: 2
Joined: Wed Feb 15, 2017 5:02 pm

Cooker hood carbon filters

“Carbon
Did you know that carbon and replaceable grease filters should be replaced every six months or, approximately sixty hours of use or they are ineffective and degrade performance? You can buy replacement carbon cooker hood filters including many cheap compatible hood filters in our store here to fit all major cooker hood makes

by electrofix » Wed Feb 15, 2017 6:58 pm

you think its broken

Why ? what is it doing ?

Dave
User avatar
electrofix
Appliance Forum Moderator
Appliance Forum Moderator
 
Posts: 4084
Joined: Thu Jun 02, 2005 12:00 am
Location: merseyside

by kwatt » Wed Feb 15, 2017 7:51 pm

Dave's right to ask as, if it's not working at all it's more likely to be the switch unit, this one:

http://shop.ukwhitegoods.co.uk/15100005 ... rol-switch

K.
"Sometimes you get the best light from a burning bridge" Don Henley

Domestic appliance spare parts Find an appliance engineer here
User avatar
kwatt
Appliance Forum Administrator
Appliance Forum Administrator
 
Posts: 25457
Joined: Sun Jun 15, 2003 12:00 am
Location: Scotland

by Cameron Bruce » Fri Feb 17, 2017 3:03 pm

Hi guys,

The lights work on the unit and the light goes on when I try to activate the fan, but the fan doesn't go on.

What do you think?

Regards,

Cameron
User avatar
Cameron Bruce
Whitegoods Newbie
Whitegoods Newbie
 
Posts: 2
Joined: Wed Feb 15, 2017 5:02 pm

by kwatt » Fri Feb 17, 2017 3:14 pm

As a service call that'd be a take a motor and switch unit one... no way to be sure till you test it.

But on balance, I'd still reckon the switch unit as the prime suspect.

K.
"Sometimes you get the best light from a burning bridge" Don Henley

Domestic appliance spare parts Find an appliance engineer here
User avatar
kwatt
Appliance Forum Administrator
Appliance Forum Administrator
 
Posts: 25457
Joined: Sun Jun 15, 2003 12:00 am
Location: Scotland




Return to General Enquiries And Questions