UK Whitegoods Domestic Appliance Help & Support Forums

General Enquiries And Questions

No spark on bush grill

General questions of any nature relating to the appliance industry can be posted here or questions about the UK Whitegoods appliance website or forums

Spare parts for all domestic appliances

“Spare
Get spare parts including accessories and filters for your kitchen appliances in our store for all major makes and models including many low cost spares or contact us and we will find the parts for you

 Support The Repair Community

How you can help in supporting out community is simple, just just use repairers from our online repair search if you need an appliance repaired

Buy any parts you need in our store that helps fund and maintain this website and the free use of it.

Don't use an adblocker.

That's all you need to do and we all appreciate your support and assistance.


by westacre » Wed Aug 16, 2017 1:50 pm

Hi, there is no spark coming on my Bush AG56DA This is in the top oven, the oven ignites fine but the grill is not sparking. Do you have any ideas? Thanks
User avatar
westacre
Whitegoods Newbie
Whitegoods Newbie
 
Posts: 2
Joined: Sun Aug 13, 2017 3:53 pm

 Before you post it… search it!

Please, before you post and ask something that has been asked before (often many times) please use the search facilities available.

Here you can search the forums only, including trade forums with permissions

Here you can search the entire site including all articles, public forums and online store

Use the search function before you post!

by electrofix » Wed Aug 16, 2017 1:54 pm

it could be various things but the only thing you can look at is the spark electrode.
look at the wire going to it. Has it fallen off. Then look in the dark as you try to light it. can you see a spark but its not in the right place so may be a faulty electrode

after that your in the realms of gas safety so we cannot help or condone you to take it apart

Dave
User avatar
electrofix
Appliance Forum Moderator
Appliance Forum Moderator
 
Posts: 6533
Joined: Thu Jun 02, 2005 12:00 am
Location: merseyside

by zibit » Fri Aug 10, 2018 2:36 pm

strange, but you can try what electrofix had told you
User avatar
zibit
Whitegoods Newbie
Whitegoods Newbie
 
Posts: 4
Joined: Wed Aug 08, 2018 6:56 pm




Return to General Enquiries And Questions