Announcement

Collapse
No announcement yet.

Beko not filling/starting

Collapse

Qualtex

Collapse

Appliance Spare Parts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beko not filling/starting

    Hi first post here, beko dw5410w not filling and no fault lights, checked the bottom tray float no stuck,drain not clogged,drain pump working, no supply to fill valve. Turn on to first proram and does nothing. Can force drain pumo on holding button in and pumps fine. Cant see a level probe or pressure switch just a counter after the fill valve think got to do with salt regen, any help appreciated(im a fridge engineer)

  • #2
    have you checked door switch ?

    Dave

    Comment


    • #3
      Hi dave not checked but when start program it does drain first so im assuming it would not if door switch was faulty, i have replaced pcb and flow counter also.hitting a brick wall now

      Comment


      • #4
        don't assume some machines will still pump with the door open

        Dave

        Comment


        • #5
          Door switch checked and is ok, im thinking fault is on wiring harness from pcb to fill valve, nothing else holding it out, do you know if these mahines break the neutral,i have 220v to fill valve but no neutral,jumped a neutral and valve energises but obv keeps filling and consequently draining down now,

          Comment


          • #6
            try checking the overflow microswitch in the base from memory think that stops the fill circuit when activated

            also is correct model no DWD5410W

            Dave

            Comment


            • #7
              Hi Dave model number is DWD5414S checked the microsurgery in the base and that checks out ok, just don't get a neutral to the fill valve but I am getting a live, haven't had any luck finding a wiring diagram

              Comment


              • #8
                Microswitch auto correct lol

                Comment


                • #9
                  live is fed to the valve all the time it then gets its neutral from the pcb terminal 7 green wire. the neutral is switched by the board triacs

                  I would check you have continuity between plug neutral and terminal 2 (Black) Also see if you have continuity between terminal 3 (brown ) and terminal 8 (orange )

                  do it with the plug off to avoid false readings
                  if these two do give a continuity reading you could check the neutral feed wire to the valve from terminal terminal 7 (green) to the valve

                  Dave

                  Comment

                  Affresh

                  Collapse
                  Working...
                  X