Announcement

Collapse
No announcement yet.

Dishwasher Impeller feels springy

Collapse

Qualtex

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dishwasher Impeller feels springy

    Bosch classixx narrow form dishwasher, freestanding. Probably 10 years old or so.

    Not draining, shows check water light and making low grinding noise even when door is open. I have cleaned the filter, bailed out the hole, removed the impeller cover and fished about for debris with no success.

    The impeller does not move completely freely and feels springy when turned (though it does turn). No amount of turning it seems to change this.

    Does this sound like something deeper in is causing the elastic sensation? Or is the pump gibbed? Thanks

  • #2
    that's normal don't worry about it

    you may have dislodged what was jamming the pump when you removed the cover

    the fact that it make a noise when the door is open may indicate there is water in the works underneath where the motor is. there is a safety float switch that cancels the programme and runs the pump

    Dave

    Comment


    • #3
      OK, thanks for that Dave.

      I have put it all back together and it is still not starting its cycle. Making plenty noise but no water sloshing etc. and no change to the dirty dishes after 20 mins testing. The water has been sponged out so fairly dry in the hole. Have had it off and on at the wall. Any tips from here?

      Comment


      • #4
        we need to figure out what happens and when

        the unit should pump for a bit then the pump will stop and it will fill. its very quiet when it fill so if you want to watch it you will have to take the left side off

        it should then start washing

        we need an Enr number and an FD number off the unit so we know which machine you are talking about

        Dave

        Comment


        • #5
          E-Nr SRS43C22GB/03
          FD 8609
          Bosch Classixx slimline dishwasher

          Now when i run it, it makes plenty noise but doesn't fill.
          It's completely drained now.

          Comment


          • #6
            will look it up

            for your interest was built sept 2006

            Dave

            Comment


            • #7
              Update. I took the filters out and replaced them and this time it seems to be working! Delighted. Thanks for all your help/support Dave.

              Comment


              • #8
                if it causes problems again take the left side off and there is a chamber at the bottom that can gunge up over time along with the pipe that leaves this chamber and goes to the sump

                Dave

                Comment

                Cheap Spare Parts

                Collapse

                Affresh

                Collapse
                Working...
                X